WordPress: Bilder werden nicht hochgeladen, Fenster bleibt leer

Gelöst: Wie ärgerlich, ich lade ein Bild in WordPress hoch und es klappt nicht. Gerade eben hat es noch funktioniert. Es wird auch ein Objekt angelegt, doch das Fenster bleibt leer. Eine Fehlermeldung, die mir einen Hinweis geben könnte erscheint auch nicht.

Das ist ein Beispiel für ein Bild, das ich hochladen möchte:

WordPress Fehler Bild hochladen original

Und das ist das Ergebnis in der Media Library:

WordPress Fehler Bild hochladen 2

Lösung:
WordPress (in der Standardinstallation) kann mit deutschen Umlauten (ä, ö, ü) nicht umgehen. Die Bilddatei trägt den Namen: „Schöner LKW.png“ – das ö war in diesem Fall also der Übeltäter. Einfach die Bilddateien folgendermaßen umbenennen: ä -> ae, ö -> oe, ü -> ue, dann klappt das Bilder-Hochladen wieder wie am Schnürchen.

Plesk: Datenbank anlegen

Plesk ist auf Bequemlichkeit getrimmt, dementsprechend geschmeidig funktioniert das Anlegen einer Datenbank:

1.) Clicke auf „Websites & Domains“ -> Datenbanken -> „Neue Datenbank hinzufügen“. Dann wählst Du einen sprechenden Namen aus und bestätigst.

plesk-datenbank-anlegen

2.) Und da das Anlegen einer Datenbank witzlos ist, auf die man keinen Zugriff hat, legt man gleich noch einen Datenbank-Nutzer an: Clicke auf „Neuen Datenbankbenutzer hinzufügen“. Suche einen sprechenden Namen und ein Passwort aus, welche Du Dir sicher notierst.

plesk-datenbank-user-anlegen

So sieht’s dann aus:

plesk-datenbank-angelegt

WordPress: Multisite Network deinstallieren

Du magst WordPress Multisite Network nicht mehr und möchtest zurück zur WordPress Single-Site?
Hier findest Du die Anleitung in 4 Schritten:

1.) Backup Deiner mysql-Datenbank

2.) Entferne alle Extra-Seiten, wenn Du sie wirklich nicht mehr brauchst

wordpress-network-rollback

3.) Schreib in die .htaccess wieder die ursprünglichen Zeilen:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

4.) Lösche aus der wp-config.php folgende 6 Zeilen:

define(‚MULTISITE‘, true);
define(‚SUBDOMAIN_INSTALL‘, false);
define(‚DOMAIN_CURRENT_SITE‘, ‚it-kosmopolit.de‘);
define(‚PATH_CURRENT_SITE‘, ‚/‘);
define(‚SITE_ID_CURRENT_SITE‘, 1);
define(‚BLOG_ID_CURRENT_SITE‘, 1);